// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"value\":\s*(?:[^;]*;){1}(.*?);"#).unwrap();
let string = "{
\"item0\": {
\"sumstate\": {
\"value\": \"0.54;10.35;239.18;14848.72;10.00;kWh;kW;1665;3035;3290;1365;2380;3105;2935;2730;1;\"
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}