package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<transaction_date>\d+/\d+)\s*(?P<description>.*?)\s*(?P<amount>[\d.,]+)$`)
var str = `06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38
07/07 MORNING BITES CAFE SINGAPORE SG 4.20
13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}