import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<transaction_date>\\d+/\\d+)\\s*(?P<description>.*?)\\s*(?P<amount>[\\d.,]+)$";
final String string = "06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38\n"
+ "07/07 MORNING BITES CAFE SINGAPORE SG 4.20\n"
+ "13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}