use strict;
my $str = '06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38
07/07 MORNING BITES CAFE SINGAPORE SG 4.20
13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20';
my $regex = qr/(?P<transaction_date>\d+/\d+)\s*(?P<description>.*?)\s*(?P<amount>[\d.,]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}