import re
regex = re.compile(r"(?P<transaction_date>\d+/\d+)\s*(?P<description>.*?)\s*(?P<amount>[\d.,]+)$", flags=re.MULTILINE)
test_str = ("06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38\n"
"07/07 MORNING BITES CAFE SINGAPORE SG 4.20\n"
"13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")