import Foundation
let pattern = #"(?P<transaction_date>\d+/\d+)\s*(?P<description>.*?)\s*(?P<amount>[\d.,]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
06/07 URBAN TRANSIT CO. SINGAPORE SG 1.38
07/07 MORNING BITES CAFE SINGAPORE SG 4.20
13/07 SUNRISE TOAST HAVEN SINGAPORE SG 3.20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)