using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\r?\n(?!\*{1,}END\*{1,})";
string substitution = @"$1,";
string input = @"abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}