const regex = /^(\d+)\r?\n(?!\*{1,}END\*{1,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\r?\\n(?!\\*{1,}END\\*{1,})', 'gm')
const str = `abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);