re = /^(\d+)\r?\n(?!\*{1,}END\*{1,})/m
str = 'abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***'
subst = '$1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result