import Foundation
let pattern = #"^(\d+)\r?\n(?!\*{1,}END\*{1,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)