use strict;
my $str = 'abc
1
2
3
4
5
***END***
abc
6
7
8
9
***END***
abc
10
11
12
***END***';
my $regex = qr/^(\d+)\r?\n(?!\*{1,}END\*{1,})/mp;
my $subst = '$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";