import re
regex = re.compile(r"^(\d+)\r?\n(?!\*{1,}END\*{1,})", flags=re.MULTILINE)
test_str = ("abc\n"
"1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"***END***\n"
"abc\n"
"6\n"
"7\n"
"8\n"
"9\n"
"***END***\n"
"abc\n"
"10\n"
"11\n"
"12\n"
"***END***")
subst = "$1,"
result = regex.sub(subst, test_str)
if result:
print(result)