# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?={{)(.*?)}}/sads/g;t' <<< "Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href=\"{{iure}}\">reprehenderit</a> qui <a href=\"{{ news }}\">in</a> ea.\"
"