$re = '/(?={{)(.*?)}}/';
$str = 'Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum
<a href="{{iure}}">reprehenderit</a> qui <a href="{{ news }}">in</a> ea."
';
$subst = "sads";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;