import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\{\\{)(.*?)\\}\\}";
final String string = "Nemo enim ipsam voluptatem quia {{ voluptas }} labore et {{ dolore }} eum \n"
+ " <a href=\"{{iure}}\">reprehenderit</a> qui <a href=\"{{ news }}\">in</a> ea.\"\n\n";
final String subst = "sads";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}