#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))"
Local $sString = "http://host.com" & @CRLF & _
"some text http://localhost" & @CRLF & _
"Some text" & @CRLF & _
"[Link Text](https://url.com "Optionl Alt")" & @CRLF & _
"" & @CRLF & _
"[Link Text 2](http://url.com "Optionl Alt 2")" & @CRLF & _
"" & @CRLF & _
"[Link Text without alt](https://url.com)" & @CRLF & _
"" & @CRLF & _
"dummy link http://dummy.com " & @CRLF & _
"" & @CRLF & _
"https://none.edu asdsf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")