$re = '/(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))/m';
$str = 'http://host.com
some text http://localhost
Some text
[Link Text](https://url.com "Optionl Alt")
[Link Text 2](http://url.com "Optionl Alt 2")
[Link Text without alt](https://url.com)
dummy link http://dummy.com
https://none.edu asdsf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);