import re
regex = re.compile(r"(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))", flags=re.MULTILINE)
test_str = ("http://host.com\n"
"some text http://localhost\n"
"Some text\n"
"[Link Text](https://url.com \"Optionl Alt\")\n\n"
"[Link Text 2](http://url.com \"Optionl Alt 2\")\n\n"
"[Link Text without alt](https://url.com)\n\n"
"dummy link http://dummy.com \n\n"
"https://none.edu asdsf\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")