// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))"#).unwrap();
let string = "http://host.com
some text http://localhost
Some text
[Link Text](https://url.com \"Optionl Alt\")
[Link Text 2](http://url.com \"Optionl Alt 2\")
[Link Text without alt](https://url.com)
dummy link http://dummy.com
https://none.edu asdsf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}