package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))`)
var str = `http://host.com
some text http://localhost
Some text
[Link Text](https://url.com "Optionl Alt")
[Link Text 2](http://url.com "Optionl Alt 2")
[Link Text without alt](https://url.com)
dummy link http://dummy.com
https://none.edu asdsf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}