use strict;
my $str = 'http://host.com
some text http://localhost
Some text
[Link Text](https://url.com "Optionl Alt")
[Link Text 2](http://url.com "Optionl Alt 2")
[Link Text without alt](https://url.com)
dummy link http://dummy.com
https://none.edu asdsf
';
my $regex = qr/(?:(?:\[(?<text>.*)\])(?:\((?<url>https?\:\/\/.*?)(?:\s\"(?<alt>.*?)\"\)|\)))|(?<text>(?<url>https?\:\/\/\S*)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}