#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?://)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(/([-\w/_.]*(?:\?\S+)?)?)*)\b"
Local $sString = "example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"http://www.example.com " & @CRLF & _
"https://example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"Deciaml Values (1.11)" & @CRLF & _
"" & @CRLF & _
"IP Address (123.123.123.123)" & @CRLF & _
"" & @CRLF & _
"W.H.O" & @CRLF & _
"" & @CRLF & _
"Price values ($11.11)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")