re = /\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?:\/\/)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(\/([-\w\/_.]*(?:\?\S+)?)?)*)\b/
str = 'example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values ($11.11)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end