use strict;
my $str = 'example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values ($11.11)';
my $regex = qr~\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?://)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(/([-\w/_.]*(?:\?\S+)?)?)*)\b~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}