package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?://)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(/([-\w/_.]*(?:\?\S+)?)?)*)\b`)
var str = `example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values ($11.11)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}