const regex = new RegExp('\\b(?+\\b|\\d+(?:\\.\\d+)+\\S+\\b)((https?://)?([-\\w]+\\.[-\\w.]+)+\\w(?::\\d+)?(/([-\\w/_.]*(?:\\?\\S+)?)?)*)\\b', 'g')
const str = `example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values (\$11.11)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}