import Foundation
let pattern = #"\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?://)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(/([-\w/_.]*(?:\?\S+)?)?)*)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values ($11.11)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)