// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?+\b|\d+(?:\.\d+)+\S+\b)((https?://)?([-\w]+\.[-\w.]+)+\w(?::\d+)?(/([-\w/_.]*(?:\?\S+)?)?)*)\b").unwrap();
let string = "example.com
www.example.com
http://example.com
http://www.example.com
https://example.com
https://www.example.com
Deciaml Values (1.11)
IP Address (123.123.123.123)
W.H.O
Price values ($11.11)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}