using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)fax\s*\:\s*\+?[\/\(\d\)\s-,]+\d";
string input = @"Fax: (91-44) 7781 1234
FAX: +91 44 7781 1234,2828 1111
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}