import re
regex = re.compile(r"(?i)fax\s*\:\s*\+?[\/\(\d\)\s-,]+\d")
test_str = ("Fax: (91-44) 7781 1234\n"
"FAX: +91 44 7781 1234,2828 1111\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")