const regex = /(?i)fax\s*\:\s*\+?[\/\(\d\)\s-,]+\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)fax\\s*\\:\\s*\\+?[\\\/\\(\\d\\)\\s-,]+\\d', 'g')
const str = `Fax: (91-44) 7781 1234
FAX: +91 44 7781 1234,2828 1111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}