// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)fax\s*\:\s*\+?[\/\(\d\)\s-,]+\d").unwrap();
let string = "Fax: (91-44) 7781 1234
FAX: +91 44 7781 1234,2828 1111
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}