re = /(?i)fax\s*\:\s*\+?[\/\(\d\)\s-,]+\d/
str = 'Fax: (91-44) 7781 1234
FAX: +91 44 7781 1234,2828 1111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end