import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)fax\\s*\\:\\s*\\+?[\\/\\(\\d\\)\\s-,]+\\d";
final String string = "Fax: (91-44) 7781 1234\n"
+ "FAX: +91 44 7781 1234,2828 1111\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}