# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a[^>]*)>([^<]*)(<\\/a>)/$1 aria-label="$2">$2$3/g;t' <<< "<ul>
<li><a href=\"www.google.com\" target=\"blank\">Google</a></li>
<li><a href=\"www.yahoo.com\" target=\"blank\">Yahoo</a></li>
<li><a href=\"www.bing.com\" target=\"blank\">Bing</a></li>
</ul>"