package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a[^>]*)>([^<]*)(<\/a>)`)
var str = `<ul>
<li><a href="www.google.com" target="blank">Google</a></li>
<li><a href="www.yahoo.com" target="blank">Yahoo</a></li>
<li><a href="www.bing.com" target="blank">Bing</a></li>
</ul>`
var substitution = "$1 aria-label="$2">$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}