// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<a[^>]*)>([^<]*)(<\/a>)").unwrap();
let string = "<ul>
<li><a href=\"www.google.com\" target=\"blank\">Google</a></li>
<li><a href=\"www.yahoo.com\" target=\"blank\">Yahoo</a></li>
<li><a href=\"www.bing.com\" target=\"blank\">Bing</a></li>
</ul>";
let substitution = "$1 aria-label=\"$2\">$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}