import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a[^>]*)>([^<]*)(<\\/a>)";
final String string = "<ul>\n"
+ "<li><a href=\"www.google.com\" target=\"blank\">Google</a></li>\n"
+ "<li><a href=\"www.yahoo.com\" target=\"blank\">Yahoo</a></li>\n"
+ "<li><a href=\"www.bing.com\" target=\"blank\">Bing</a></li>\n"
+ "</ul>";
final String subst = "$1 aria-label=\"$2\">$2$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}