re = /(<a[^>]*)>([^<]*)(<\/a>)/
str = '<ul>
<li><a href="www.google.com" target="blank">Google</a></li>
<li><a href="www.yahoo.com" target="blank">Yahoo</a></li>
<li><a href="www.bing.com" target="blank">Bing</a></li>
</ul>'
subst = '$1 aria-label="$2">$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result