#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=>)[0-9A-za-z]*(?=<\/a>)"
Local $sString = "<div class="termWrap "><a class="color1" href="/terms/?q=colors" target="_blank">09120000000</a><sup title="Frequency in the text">474</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=designers" target="_blank">09120000000</a><sup title="Frequency in the text">67</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=pantone" target="_blank">09120000000</a><sup title="Frequency in the text">53</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hue" target="_blank">09120000000</a><sup title="Frequency in the text">44</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=palette" target="_blank">09120000000</a><sup title="Frequency in the text">43</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=printing" target="_blank">09120000000</a><sup title="Frequency in the text">39</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hues" target="_blank">09120000000</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")