import re
regex = re.compile(r"(?<=>)[0-9A-za-z]*(?=<\/a>)", flags=re.MULTILINE)
test_str = "<div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=colors\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">474</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=designers\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">67</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=pantone\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">53</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=hue\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">44</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=palette\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">43</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=printing\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">39</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=hues\" target=\"_blank\">09120000000</a>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")