import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)[0-9A-za-z]*(?=<\\/a>)";
final String string = "<div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=colors\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">474</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=designers\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">67</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=pantone\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">53</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=hue\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">44</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=palette\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">43</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=printing\" target=\"_blank\">09120000000</a><sup title=\"Frequency in the text\">39</sup></div><div class=\"termWrap \"><a class=\"color1\" href=\"/terms/?q=hues\" target=\"_blank\">09120000000</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}