use strict;
my $str = '<div class="termWrap "><a class="color1" href="/terms/?q=colors" target="_blank">09120000000</a><sup title="Frequency in the text">474</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=designers" target="_blank">09120000000</a><sup title="Frequency in the text">67</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=pantone" target="_blank">09120000000</a><sup title="Frequency in the text">53</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hue" target="_blank">09120000000</a><sup title="Frequency in the text">44</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=palette" target="_blank">09120000000</a><sup title="Frequency in the text">43</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=printing" target="_blank">09120000000</a><sup title="Frequency in the text">39</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hues" target="_blank">09120000000</a>';
my $regex = qr/(?<=>)[0-9A-za-z]*(?=<\/a>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}