using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[0-9A-za-z]*(?=<\/a>)";
string input = @"<div class=""termWrap ""><a class=""color1"" href=""/terms/?q=colors"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">474</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=designers"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">67</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=pantone"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">53</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=hue"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">44</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=palette"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">43</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=printing"" target=""_blank"">09120000000</a><sup title=""Frequency in the text"">39</sup></div><div class=""termWrap ""><a class=""color1"" href=""/terms/?q=hues"" target=""_blank"">09120000000</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}