const regex = /(?<=>)[0-9A-za-z]*(?=<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>)[0-9A-za-z]*(?=<\\\/a>)', 'gm')
const str = `<div class="termWrap "><a class="color1" href="/terms/?q=colors" target="_blank">09120000000</a><sup title="Frequency in the text">474</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=designers" target="_blank">09120000000</a><sup title="Frequency in the text">67</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=pantone" target="_blank">09120000000</a><sup title="Frequency in the text">53</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hue" target="_blank">09120000000</a><sup title="Frequency in the text">44</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=palette" target="_blank">09120000000</a><sup title="Frequency in the text">43</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=printing" target="_blank">09120000000</a><sup title="Frequency in the text">39</sup></div><div class="termWrap "><a class="color1" href="/terms/?q=hues" target="_blank">09120000000</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}