package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(^\d{4}-\d{3}?)(.*)`)
var str = `#Valid:
1234-567 ABCD efgh
1600-141 Lisboa
#Invalid:
1234567
1234 567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}