import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{4}-\\d{3}?)(.*)";
final String string = "#Valid:\n"
+ "1234-567 ABCD efgh\n"
+ "1600-141 Lisboa\n\n"
+ "#Invalid:\n"
+ "1234567\n"
+ "1234 567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}