re = /(^\d{4}-\d{3}?)(.*)/mi
str = '#Valid:
1234-567 ABCD efgh
1600-141 Lisboa
#Invalid:
1234567
1234 567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end