import re
regex = re.compile(r"(^\d{4}-\d{3}?)(.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("#Valid:\n"
"1234-567 ABCD efgh\n"
"1600-141 Lisboa\n\n"
"#Invalid:\n"
"1234567\n"
"1234 567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")