$re = '/(^\d{4}-\d{3}?)(.*)/mi';
$str = '#Valid:
1234-567 ABCD efgh
1600-141 Lisboa
#Invalid:
1234567
1234 567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);